Images to Art-net

mrpackethead's picture

Just following on from the other thread.. 'Problems with Art-net' is not really the right topic any longer.. Chris has provided some useful information as to what is problematic.

Quote:
There aren't any Image->structure patches in QC, but it wouldn't be particularly difficult to make one. If I had more time, I could whip one up for you.

Would money create some time? This is something i'd pay for ( or help pay for ).. I might have to learn how to program these patches otherwise. But i've already got enough projects on the go.

Quote:
The reason 3600 dies in QC is because StructureMaker has a bug.... I added drawing/update disabling while it adds or removes ports, and now it's significantly faster (see attached images).

Nice.. Actually i left my mac running last night with 512 and it eventually got there ( sometime before i woke up ).. This is a really good start

Quote:
Let me know if you want to try the beta.

Yes, please!

NB, wheres the best place to start learning this magic? I'm a resonably proficent C coder, and can figure out most things given enough time.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

mrpackethead's picture
Re: Images to Art-net

I thinks we found what we need

http://www.magdatt.nl/software.html

ALmost accidently!

franz's picture
Re: Images to Art-net

brilliantly wunderbar !!! i love you

12288 members, and still 60FPS... A.W.E.SOME !

mrpackethead's picture
Re: Images to Art-net

Yes, i've just been playing with this, and it really looks like its going to do the biz..

Now, i'm going to show my quartz newbie-ism.. Plse see attached patch.

How can i pull the indivudal elements out of the Component Structures, add a key, and get them into a structure that the art-net patch likes, without having to map everyone individually like this? Is there a better way?

Once i get the beta of the strut tools from chris, i think i might be close to redirecting efforts back to the creative side of this project..

I'm glad i've perserved with this, cause this WILL be good.

PreviewAttachmentSize
imagetoartnet.qtz10.64 KB

mrpackethead's picture
Re: Images to Art-net

Having some sucess now, but not entirely.. I'm getting dmx to my end devices, but its all broken up.. I'm not sure if its my art-net bridge however..

More testing!

cybero's picture
Re: Images to Art-net

Excellent find - more good plugins

mrpackethead's picture
Re: Images to Art-net

I'm really pleased to report, i have now got a fantastic quartz--> art-net ---> dmx512 system running for my pixels.

Thanks Chris for the Beta version, that solved many problems.

The method i'm using also doubles up as a very easy (and cheap)way of attaching an enttec Pro dongle to quartz. ( all on the same machine )..

I'll be writing this up shortly as a HOW TO Guide..

franz's picture
Re: Images to Art-net

oh ! do you mean you're using the enttect DMX USB Pro, and not the ODE ArtnEt node ? If yes, did FTDI solved their driver issues ?

mrpackethead's picture
Re: Images to Art-net

Yes, I did mean i'm using a DMX USB Pro. :-)

I have a very small footprint knoppix based virtual machine running as an art-net to DMX bridge. So its not running under MacOS directly. So quartz outputs Art-net on a virtual NIC, which the bridge vm listens to, and via the USB to the enttec pro.

I'm going to move the virtual machine to a physical machine and attach 8 USB-->DMX 'dongles' to it. THey will actually are not enttec dongles, but a ATMEGA based dongle that behaves just like an enttec, and works with the enttec design.. I'll build a single pcb with 8 universes on it. I'll be using a little ITX motherboard, the whole thing will sit in a 1U 19" rack case, and i should be able to put it together for about $NZ400, ( US $250 ).. Which i reckon is really cheap!

Now i have some awesome patches.. I'll have to learn how to put together some great stuff to drive my pixels.. I'm so glad i did'nt give up when things got hard!

mrpackethead's picture
Re: Images to Art-net

Heres a bit of a video of the glue to make this work. The RGB pixel on display is display pixel (0,0) of the image.. I was too lazy to bring in the rest of them inside, and its way too cold in the shed at the moment.. I will this week, set them all up for a play.

FYI, the art-net bridge is running as a virtual machine on the macbook under fusion.. ( ie Quartz is not talking directly to the entec pro )

usefuldesign.au's picture
Re: Images to Art-net

Dude, the video says I have to accept an friends invitation to view it. Admittedly we are not friends, but that's no reason to be so unfriendly! LOl

gtoledo3's picture
Re: Images to Art-net

Berry eenteresting.

mrpackethead's picture
Re: Images to Art-net

usefuldesign.au wrote:
Dude, the video says I have to accept an friends invitation to view it. Admittedly we are not friends, but that's no reason to be so unfriendly! LOl

Sorry, did an auto-upload from imovie, and did'nt click the right things! Doh. Fixed now