Running QC 3.x In Snow Leopard

toneburst's picture

I've got Snow Leopard running, and just noticed that QC 3.1 still runs! Is there any point running v.3.x in SN, for downward-compatibility with Leopard, or does the fact that it's using the v.4 framework mean that this would be a pointless endeavour?

a|x

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cwright's picture
Re: Running QC 3.x In Snow Leopard

pros: you get the old-style patcherator/behaviour.

cons: it's using the QC4 framework, so it inherits all the lousiness (and hopefully eventually fanciness) of QC4.

cybero's picture
Re: Running QC 3.x In Snow Leopard

If you search the recent SL / L QC3 or QC 4 discussions, many contributions made therein from dust who has had a similar result to yourself when installing SL, with QC 3 still available.

toneburst's picture
Re: Running QC 3.x In Snow Leopard

cybero wrote:
If you search the recent SL / L QC3 or QC 4 discussions, many contributions made therein from dust who has had a similar result to yourself when installing SL, with QC 3 still available.

Ah, OK. I'm a bit out-of-the-loop at the moment. As I mentioned on other threads, I've only just got Snow Leopard installed (about 3 hours ago, in fact).

a|x

toneburst's picture
Re: Running QC 3.x In Snow Leopard

Gotcha. Cheers cwright.

a|x

dust's picture
Re: Running QC 3.x In Snow Leopard

i will give you an example why i run qc 3 in snow leopard. im taking a multi touch class and i need the tuio plugin. well i built it for 10.6 but it doesn't show up as a valid plugin but it does in qc3 on sl so this in turn lets me build a qc builder app that will run in sl with qc 3 that will run the tuio plugin. i have been finding lots of leopard builds that i can not open in qc4 but they open in qc3 so for the time being im using both and making builds for snow. somethings like gltools runs way to slow 3fps for something that gets 40fps normally so i just save the document and build a qb app that will run gltools on SL at a much better frame rate. until kineme and others update stuff im willing to deal with some quirkiness and using 2 versions of qc and qb to get things working on SL.

Troy's picture
Re: Running QC 3.x In Snow Leopard

Most likely, the plugin you are missing is compiled 32-bits and QC for SnowLeopard is 64bits. You could try running QC as a 32-bit app by selecting it in Finder, Get Info, and checking the box that opens it as a 32-bit application.