How to control amount of time before note-off with the MIDI-plugin

yoki's picture

yo boys (and girls? :) ))

i am making a small sequencer fwhich outputs notes using the global midi outeput note-patch.. the sequencer is basicly parsing an array of booleansinto the gate of the midiplugin. the problem i have is that when two note-ons are coming after eachother there wont be a note-off , (i dont know how to "time" a pr note-off after each note on since there are no lfo:s or other time-tools in qc which is possible to reset on each note-on) is there any wworkaround this? it would be really sweet in coming versions of the note out plugin if one could specify the length of each note in milliseconds or whatever..

(sorry if this text is unreadable, ithe textbox s on this site does not work with firefox at all so i cant see what i am writing :) )


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cwright's picture

There are no girls on the internet, and especially no girls on Kineme :( (Actually there are a couple...)

You could try messing with the stopwatch patch with some math glue to timeout note triggers. I'm not sure how well it would work, but it's a start. I'll think about a way to do this inside the patch in the mean time...

Which version of firefox are you using? I use that almost exclusively, and haven't had any problems (using 2.0.0.x or any of the Beta 3's)

bbinkovitz's picture
girls, girls, girls

Hey Chris, no girls on the internet? Really? ;-)

psonice's picture
Timeout/site problems

Not 100% sure what you mean there (probably as I've not used midi at all), but using a stopwatch with a range patch may help?

You connect the stopwatch to a range patch, and use the clamped output of the range as the timer for your note output, LFO or whatever. Then it will play for a fixed time, depending on the max range value you feed it. And you can reset the stopwatch ready for the next note with a bit of logic feeding back from the range patch or a conditional. The signal patch is also your friend for stuff like this.. I'm sure there's a way to do it, based purely on the number of times I've fixed similar issues :)

Re. the site - I've had no issue with the text boxes (on either firefox or safari), but I noticed something else. Now and again the front page will display text instead of html, with random characters. Refreshing does nothing, but adding /index.php to the address fixes it. It's intermittent, only happens now and then, and happens at both work and home, pc and mac, firefox and safari. I'll capture the output next time I see it if it'll help.

smokris's picture
Random Characters

When is the first time you noticed the Random Characters thing happen?

psonice's picture
random characters

Not sure, I guess perhaps a week or so back?

yoki's picture
strange textbox behaviour

I am using Firefox/

I have tried to analyse the thing a bit more and the bugs kick in usually while writing certain characters like 'e' which makes the cursor hjump inside the text and also introduces lots of garbage.. i have only experience this on kineme website and also on the cycvling 74-forum

here is a screenshot of the message i am writing now

the second-line garbage is what happens when deleting charsss which h make edites sentences totally unreadable :) I dont experience this while using safari.. the subject-box works alright so maybe its something strange with the font used in in this window or whatever...

Thanks for the help, i will try out stopwatch at once

smokris's picture
Drupal cache implementation is fail

Though I haven't personally been able to reproduce this issue.. About a week ago is when we enabled Drupal's cacheing system, so I think that's likely to be the problem.

According to what you're seeing is probably the result of a cached page being double-compressed. I disabled compression of cached pages altogether as gzip compression is pretty cheap anyway (and CPU time isn't a limiting factor by any means on our webserver).

Let me know if you notice this problem again.

smokris's picture
Firefox 2.x has serious

Firefox 2.x has serious issues rendering monospace fonts in text edit boxes. I was never able to reliably reproduce the problem, but intermittently certain websites would render text like that for me, too. I've been using Firefox 3.x beta for months and haven't encountered the problem since I switched. I'm not sure if there is a workaround I can apply to, though if you find one, please let me know and I'll give it a try.

psonice's picture

Will do.