Is there a bug in the Network patches in the latest version of Quartz Composer

mwoods's picture

Hi all,

I'm new to this forum, but this seems like the most active community of Quartz Composer users, and I have a pressing question.

I am having a problem with the Network Broadcaster, Network Receiver, and Network Synchronizer patches in the latest version of Quartz Composer (Version 4.6(151)). Whenever I try to modify either the Port Number, or the first field of the IP address in the settings of these patches, I get a beep and the value isn't modified. I can see no messages in the console. I have tried this on two different machines, both running Mavericks and the latest version of QC. The patches seem to work with their default values, but I can't do anything to change the values.

Has anyone else experienced this? Does anyone have an idea of how to work around it?

Thank you for your help!

-Matt

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Achim Breidenbach's picture
Re: Is there a bug in the Network patches in the latest ...

In the RFV 1112 there is specified the IP range where Multicast is transmitted, thats why you cant enter "any" IO addresse if you select the "Multicast" option:

http://tools.ietf.org/html/rfc1112

"4. HOST GROUP ADDRESSES

... from 224.0.0.0 to 239.255.255.255 ...

"

Use the "Broadcast" option. Just my two cents.

mwoods's picture
Re: Is there a bug in the Network patches in the latest ...

Hmmm.... helpful. Thanks. Broadcast seems to work ok for sending. I'm having problems with receiving though. Does the receiver only receive messages from another quartz composer broadcast patch? I am trying to communicate with a udp testing tool on my iPhone. I can send messages from my qc composition using broadcast to the correct port number. I can't seem to receive them though. Ultimately, I will be wanting to communicate via udp with an AMX controller.

Thanks for your help.

-Matt