Mavericks = trouble

yourbartender's picture

Has anyone else experienced these problems with Mavericks?

a) cannot save. QC lets me save once in the beginning, then every time I want to save it says "The document "filename.qtz" could not be saved". I've set the permissions temporarily to chmod ugo+rwx for this file. Will next run disk Utility - repair permissions

b) lost QC file icons - No blue icon for .qtz files, no "preview", nothing on QuickLook

c) Images are rendered really crappily. If I make e.g a JPG image larger or smaller, it looks like shit. No antialaising, nothing.

If all these are working perfectly for you all, perhaps I need to do a clean install or something. All in all, move to Mavericks has been a real pain in the ass, there are many other problems I've had to fix.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

shaun's picture
Re: Mavericks = trouble

I'm having the exact same problem. Did you get it fixed?

yourbartender's picture
Re: Mavericks = trouble

No fixes yet. I repaired permissions, no help. I made a bug report to Apple. Forces me to save versions, which in a sense is good but frustrating.

Alexander Mitchell's picture
Re: Mavericks = trouble

Are you using the newest QuartzComposer?

Version 4.6 (151) Framework Version 5.1 (316)

harryjones's picture
Re: Mavericks = trouble

Same issue here. Unable to save Quartz Composer files. I get these errors: http://cl.ly/image/3f0p1U103Z0J

I've tried removing and reinstalling QC, removing the QC Library and Application Support files and repairing disk permissions but still won't save after the file is initially created and saved once.

I'm using the latest version of QC: Version 4.6 (151), Framework Version 5.1 (319)

knaut's picture
Re: Mavericks = trouble

Been using Mavericks on my Macbook Air, OS v10.9.2. No issues with saving or otherwise. QC version 4.6 (148), Framework Version 5.1 (319)

Maybe the 151 version has issues? I've been thinking of updating my main machines, a Mini, to Mavericks. Will let you know if I have any significant issues.

Achim Breidenbach's picture
Re: Mavericks = trouble

What does the Console app says in the moment you try to save your composition? Do you see any unusual outputs (e.g. sandboxd denies?)

pbourke's picture
Re: Mavericks = trouble

I have the same problem. I have two machines, same versions of everything ... OS and QC, works on one and not the other. So much be some OS setting I think. I can even remote share from one machine and save on the other problem one. Grrrr.

pbourke's picture
Re: Mavericks = trouble

OK, found the answer even though I don't understand why it occurs and what the conflict is. The problem is with the .spotlight attributes of the directory, do a get info on the directory with the non saving QC composition, remove the .spotlight attribute and saving then works. If I create a new a directory on the desktop a .spotlight attribute is automatically created. If I create one in my home directory it isn't. Sigh!

scottybee's picture
Re: Mavericks = trouble

Paul, I'm having the exact same problem and it's driving me crazy.

Sorry for the newbie question, but how exactly do you remove the .spotlight attribute from the affected folders?

thanks,

Scott

scalf's picture
Re: Mavericks = trouble

I have been able to use "Save As…" instead of "Save" for a while now. I have experienced the same problem though - very unfortunate.

escuderobla's picture
Re: Mavericks = trouble

I was suffering the same problem with my Quartz, I can't save more than 1 time. I didn ´t find too much info about Quartz out there, so I start thinking about problems not with Quartz but with Mavericks and his own way to do things.

And going in this direction, I found this that totally solved the problem: https://discussions.apple.com/thread/5815693 Reset the permissions to all my home folder!

I suffered in the past another 'anomalies' about permissions with ableton, adobe suite etc. and this time, again, the same thing.

I hope this can be useful for anybody.