Problems compiling Cocoa Application using Quartz Composer View with Xcode 6.3.1

dryan04's picture

Is anyone able to create Cocoa applications for your Quartz Composer compositions since upgrading to Yosemite?

I'm pretty sure it's an issue with Xcode's implementation of the Quartz Composer View as I get the same results with an empty or nearly empty Quartz composer composition.

The error that appears in the build phase of Xcode is:

The document "MainMenu.xib" could not be opened. The operation couldn’t be completed. (com.apple.InterfaceBuilder error -1.)

I don't do Objective C so I can't dig under the hood and see what's going wrong.

Any ideas out there?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Serious Cyrus's picture
Re: Problems compiling Cocoa Application using Quartz ...

Uhmm.., just tried a quick X-Code project and got the same result. The error description isn't very helpful. I thought maybe it was because libraries weren't included or something, but that's not the case.

TBH, I avoid most of the stock Interface builder stuff for QC and use an OpenGLView instead, but that's not much help for you...

Achim Breidenbach's picture
Re: Problems compiling Cocoa Application using Quartz ...

I created a quick test project and got the following error on runtime: "QCTest[81335:9616672] Failed to set (contentViewController) user defined inspected property on (NSWindow): *** -[NSKeyedUnarchiver decodeObjectForKey:]: cannot decode object of class (QCView)"

Then I removed the QCView from the view hierarchy in Interface Builder and added it manually at runtime in viewDidLoad: method of the view controller, which did work.

- (void)viewDidLoad {
   [super viewDidLoad];
 
   // Do any additional setup after loading the view.
 
   QCView* qcview = [[QCView alloc] initWithFrame:self.view.frame];
   // do additional configuration stuff of the qcview here
   [self.view addSubview:qcview];
}