Video Loader

scalf's picture

I need some help with this video loader. I am loading videos from a folder into the composition then feeding that into the stock 'video importer' patch's location input. Some videos do not play that well in this, but do better in the v002 'movie player' patch.

When I go to plug in the file url into the v002 movie player, it is not the correct format.

Is there a correct format for alternate video player, a way to load from a folder?

Thanks

PreviewAttachmentSize
Video loader.qtz3.94 KB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cybero's picture
Re: Video Loader

Can't speak regarding the v002 Movie Player, but using the stock patches I can't reproduce your problem, see attached a simplified version of your composition. Handles H.264 and Apple Photo JPEG OK :-) . What codecs are you using ?

//Postscript//

Just updated and installed v002 Movie Player and now find I can reproduce your problem using v002 Movie Player and some .mov files that ostensibly should play AOK. I note with interest the following advice upon vade's site :-

Quote:

There is an issue with Beta 4 and some HD or larger movies. We are working on a fix. In the meantime, Beta 1 is still available.

it really is all a matter of codecs and how well the patches support these.

On another note, once one has gotten one's video assets appropriately formatted [codec-wise] there then arises the question of how to deliver these one after another - see attached timer mechanics version of your uploaded 'problem' file as one solution.

One could use timelines - see 1961 for a good example of that, XML, JavaScript too could be used.

This example uses a Boolean Watcher driven by a Conditional patch fed the movie's duration and position. If these are found to be equal a signal is sent, picked up by the Watcher and triggers an updating of the Increasing Signal Boolean input on the Counter patch forcing it to send an incremented number to the Range patch which has been set, deliberately, to cover 1 to 4, as 0 index means nothing to the Directory Importer patch, :-), thus cycling through 1 to 4 on the Index input for the Structure Index Member patch giving us the URL of the movie to be loaded.

As you can see from the second example posted, the timer mechanics works equally well with the standard Movie Importer patch .

PreviewAttachmentSize
Video loader_0.qtz4.28 KB
Video loader_01_timer.qtz8.87 KB

vade's picture
Re: Video Loader

Please post issues with v002 software on forums.v002.info - kineme is not responsible for our software ;)

Additionally, please describe in full the format of the movie you are playing.

Thanks.

vade's picture
Re: Video Loader

Cybero, same goes for you.

The issue with some HD playback is our patch uses some additional video memory, which can bog down some systems with limited VRam (thus the caveat on HD playback), which due to older Beta 1 not having to worry about 32 bit limitations, could render directly into OpenGL (Beta 4 uses a background process to handle decode which would otherwise not work on 64 bit, and we use an render to texture phase for that pass, thus the extra VRam, and possible VRam thrashing that may ensue if a system has limited amounts of VRam.).

That said, I've not seen any loading issues, so please let me know about those.

cybero's picture
Re: Video Loader

OK, will so post in future :-).

cybero's picture
Re: Video Loader

Regarding

Quote:

When I go to plug in the file url into the v002 movie player, it is not the correct format.

Is there a correct format for alternate video player, a way to load from a folder?

Using the Directory Scanner patch and parsing through the structure it provides, gives, for example, file://localhost/System/Library/Compositions/Rollercoaster.mov as an URL.

Without wishing to tread on any toes, both the Movie Importer patch and the v002 Movie Player patch you have placed in your posted composition will take such an URL.

They can also take other types of path, such as HTTP and paths like /Volumes/DriveA/Movie-Files/MeshGlow.mov.

Further details regarding v002 patches to be found on http://v002.info and on the Support forums for the v002 patches and software.

If something doesn't load then it's almost bound to be some unsupported codec related matter, unless you have managed to create a badly formatted video. I've made a few of those :-). Especially with audio video screen captures.

All of the above gets thrown out of the window for me when it comes to running QC 4.5 on Lion, but that, as they say, is another story, for another thread.

Just wondered BTW, did either of those example files work for you and are you working on Leopard or Snow?

itsthejayj's picture
Re: Video Loader

Vades movie player is excellent, but kinda feel like kineme's own video player (video tools) need a little mention here. Hope people like the h264 playback i commissioned ;)

cybero's picture
Re: Video Loader

Definitely liking the Kineme Video Tools Movie Player patches especially so, at present, in Lion, wherein almost all other video files patches fail in QC 4.5 •~. Definite thumbs up too for Vade's Movie Player too.

cybero's picture
Re: Video Loader

BTW, the issue I had with the Index of 0 not being recognized has been resolved.

It shouldn't have been happening in any case, as the Directory structure indexed members from 0 upwards.