tell qc to use specific tcp connection

elementdns's picture

hey there!

i'm running a composition using the kineme artnet tools feeding artnet to an enttec artnet ode. the subnet is in the 10.0.0.0 private adress area. everything is working very fine so far.

the only thing i can't handle is to manage qc to explicitly use the ethernet connection. each time i activate the airport connection qc seems to broadcast via airport, which makes the ode go numb.

i want qc to talk to the ode via ethernet connection and i want to vnc into the mac via remote using the airport connection using the routable connection, which is on 192.168.1.10 everything works fine when i activate airport AFTER i fired up qc. if the connection drops qc seems to prefer the airport.

is it possible to tell quartz to only use the ethernet connection?

cheers and thanks so much, dennis

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

gtoledo3's picture
Re: tell qc to use specific tcp connection

That's really interesting. I can say that I regularly use artnet tools, and when running tests, I regularly send artnet from one laptop to another, with the airport activated on both of them.

I don't think it's that qc is trying to use the airport, though I could be wrong. You should try firing up Console.app and see what messages it gives (if any) when you reproduce those steps.

One thing is, maybe, is that you say your subnet is in the 10.0.0.0 area. I'm pretty sure your IP address needs to be in that range (or 2.0.0.0 range), and your subnet needs to be in the 255.0.0.0 range.

elementdns's picture
Re: tell qc to use specific tcp connection

After comparing different scenarios i think there's still some issues with the connection routing.

This is my setting:

mac01: Ethernet connection is 10.0.0.1 / 255.0.0.0 (Running artnet sender) The enntec ode : 10.0.0.2 / 255.0.0.0 (Both are connected via ethernet, artnet works properly with airport switched off)

Now i turn on the macs Airport which has 192.168.1.110 / 255.255.255.0 and is connected to an access point offering wan (192.168.1.1)

From this point, whenever the q composition is restarted or qc itself is being relaunched, the artnet signal won't work again.

The console tells me that qc tries to talk to 10.0.0.2 (ode) through the Airport connection.

I tried to change the network settings on the mac by changing the priority settings for the connections. Moving ethernet to the top of the list. In that case other applications won't be able to connect f.e. to wan.

Maybe what i need is "application based ip-routing" that tells qc to use ethernet and all other applications to use the airport connection.

I hope that's possible because i want the mac to work with the ode and to be able to reach the mac from "outside".

cheers, dennis