Problem with STRUCURE TO FILE

voxdeserti's picture

Please Help! Got a problem with writing image histogram info to file. When I make all necessary connections and press 'write' button QC doesn't create .plist file...

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

monobrau's picture
Re: Problem with STRUCURE TO FILE

Maybe the path name is wrong? Attached a composition that works for me, saves in the same folder as the composition.

PreviewAttachmentSize
histogram.qtz5.09 KB

voxdeserti's picture
Re: Problem with STRUCURE TO FILE

The Patch is quite clear. Unfortunately I can save only a definite member of a structure - not a whole one. Strange thing...

monobrau's picture
Re: Problem with STRUCURE TO FILE

I might not understand you clearly, what are you trying to accomplish? Do you have an example composition what's going wrong?

voxdeserti's picture
Re: Problem with STRUCURE TO FILE

The same patch as you have sent works on my MBP with no result, i.e. it doesn't save a structure. I've tried to save separate members of a structure and it worked. But no result for a whole structure((

monobrau's picture
Re: Problem with STRUCURE TO FILE

That's quite strange. Did you try starting a clean QC (with only the file tools in the patches folder)? And the latest version http://kineme.net/release/FileTools/04

When you save and then load with the attached composition do you get this output when hovering with your mouse over the structure output of the structure from file patch?

PreviewAttachmentSize
screen1.jpg
screen1.jpg53.81 KB
histogram.qtz8.2 KB

bernardo's picture
Re: Problem with STRUCURE TO FILE

well are you actually reading any plist file? do you know where it is? it might be lost, or saving to a place where you have no permissions. other than installing kineme plugz i have no advice... how large is the structure? by the way if it has pictures i wont save :) hugs bern

dust's picture
Re: Problem with STRUCURE TO FILE

You could try the mesh writer plugin as well. It saves vertex data down disk. The data is the same format float4 so it should work. Got to make a 32 bit update to it but seems to be working for models. I would keep your image small. Saving a 640 x 480 image down is a lot of data and not really the preferred way to save image by any means. Although a small set of histogram data saved to disk can be useful.

voxdeserti's picture
Re: Problem with STRUCURE TO FILE

Here's a composition that doesn't save structure on my MBP.

PreviewAttachmentSize
histogram_imaging.qtz65.12 KB

monobrau's picture
Re: Problem with STRUCURE TO FILE

Loading works for me in this composition.

Please note that for the structure from file patch (or just about everything in QC) to work it should be connected to a consumer patch.

PreviewAttachmentSize
histogram_imaging_1.qtz63.21 KB

dust's picture
Re: Problem with STRUCURE TO FILE

works fine on my mac book pro. you might want to use a directory like ~/Desktop/Structure.plist to read and write from.

PreviewAttachmentSize
histogram_imaging_2.qtz92.78 KB

bernardo's picture
Re: Problem with STRUCURE TO FILE

well it works here also...

hugs bern