Missing items from Patch Inspector

cybero's picture

The following items have vanished as available patches from within the Patch Inspector, despite being installed to System/Library/Graphics/Quartz Composer Patches

Audio Processor Crop to Destination Grid Indices Grid Normals Momentum Scrolling Mesh Normals Mesh Vertices Split Track Info

is that normal for these to be installed , yet remain inaccessible from the Patch Inspector?

Are they meant to only be called upon when used by a Template or some such pre-programmed arrangement?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cybero's picture
Re: Missing items from Patch Inspector

Well, I tried clearing the cache, nil effect, still no show in the Custom patch section for the aforementioned patches, so went to look closely at the first patch that had proved to be oddly elusive, Audio Processor.

I examined this in XML format, within Text Wrangler, adding only the Apple copyright notice, not sure if that made any difference, and amending the way the framework version was stated in the file, from {156.28} to 156.28, saved the file as Audio Processor B.qtz ,authenticated and moved it back to System/Library/Graphics/Quartz Composer Patches.

It now works, shows in the Patch Inspector and all others reported above as not previously showing are also displaying [ including Track Info [HUD] ], without any other keyboard work involved.

So situation sorted, sort off.

Thing is, named as Audio Processor B, it shows up, named as Audio Processor C or as Audio Processor * it shows up [removed C and B], but named as Audio Processor, it will not show at all.

Still puzzled, despite workaround working

cybero's picture
Re: Missing items from Patch Inspector

Well, having rooted around here and there I've found the only really effective workaround is to create a custom spectrum aggregator patch which does work on both 10.5 and 10.6.

Simply reinstalling the original from the SL install disk only provoked the same problem of the Audio Processor patch not showing up in the Patch Inspector, as well as other previously reported missing patches disappearing.

No amount of my hair tearing use of dscl, accompanied by drilling down through the Install DVD to the Essentials.pkg worked around that particular problem, [which doesn't mean that can't be done to extract the required file[s] & set appropriate permissions with dscl BTW].

unpkg from http://www.timdoug.com/ proved very useful in regards of extracting the appropriate file, although I expect a lot of others will be thinking, use Pacifist.

Time consuming and distracting is this kind of procedure otherwise when run straight at the Command Line.

Once the default Audio Processor patch was removed from System/Library/Graphics/Quartz Composer Patches, the other patches reappeared in the Patch Inspector.

So home made Custom patch in home directory Library/Graphics/Quartz Composer Patches proved the most effective way to go, with no Audio Processor installed at System/Library/Graphics/Quartz Composer Patches to enable all other Custom patches that had otherwise disappeared.

It's that disappearing trick that seems to spread like a common cold that baffles me at present.