glsl not rendering in qc view.

dust's picture

can anyone confirm that they have this type of problem. I'm trying to simply load a glsl comp into a qcview via IB. any patch with glsl in it will not render once the application is built. i have tried loading the file as well as loading in the xib ? nothing ? 10.7.3 Xcode 4.3.2

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cybero's picture
Re: glsl not rendering in qc view.

Actually on 10.7.4 and am on the same Xcode as you. Just bundled a GLSL into a QC View and gave it that most extreme of treatments - full screen. it just works. what can I say?

gtoledo3's picture
Re: glsl not rendering in qc view.

Yeah, works here.

I noticed awhile back, not using QCView, but an NSView and QCRenderer that some GLSL shaders were having issues running outside of the QuartzComposer editor app, if they took input from the Video patch. I'd just get a black output.

My first thought was that all GLSL was busted, but it wound up being related to the the Video patch - jpg/png 2D texture was working ok. I tried changing the texture sampler to sample2DRect, but it didn't fix the problem. What was happening was that the GLSL shader would compile, sense no valid image input, and optimize itself "off", before it triggered the evaluation for the video patch to actually turn itself on.

Eventually, I figured out that if I connected a Billboard to the output of the Video patch, and placed it at Layer 1 (and sized it so it was invisible), it would keep the Video patch evaluating and let the shader work. That may work in your scenario?