Model Not Smooth in K3d 1.8

cat's picture

I have some 3d scans from kinect fusion, they have normals, I've attached one for you to look at... If I load them in c4d, vvvv or using v002 model loader, the mesh is smoothed, but with K3d the object is faceted, I've tried adding the normals object, etc, but it remains blocky, any ideas why? Its for a part on Saturday, so any quick ideas I can try would be appreciated! Thanks

Cat

PreviewAttachmentSize
em.obj_.zip1.98 MB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

gtoledo3's picture
Re: Model Not Smooth in K3d 1.8

Try using "smooth" setting on the actual renderer.

cat's picture
Re: Model Not Smooth in K3d 1.8

I have tried that, and every other smooth option I can see... Try the model attached in the first post in the patch attached to this one to see what I mean...

PreviewAttachmentSize
facetedissue.qtz30.11 KB
Screen Shot 2013-03-28 at 16.51.06.png
Screen Shot 2013-03-28 at 16.51.06.png134.95 KB

cwright's picture
Re: Model Not Smooth in K3d 1.8

What about if you simplify the model (I think there's a simplify patch? or a simplify input on the loader?) -- last I recall, smoothing required a simplified model (simplification in this context means that triangles will share vertices instead of each triangle having its own copy -- the vertex data itself isn't modified, just de-duplicated).

cat's picture
Re: Model Not Smooth in K3d 1.8

Couldn't see a a simplify patch, but the obj loader has a simply setting, which I've tried, also tried object to vertex structure, vertex structure to object, smooth, remesh and all combinations of them as I could find. You are right that the object has separate indices per face though, I had a look at the obj in text edit, but everything else loads it as a smooth object, just checked in photoshop too! I take it theres no other way to reindex the model in qc? Think I'd class this as a bug in the mesh loader, ie the simplify check box doesn't work with obj files from kinect fusion, should I submit this? Unfortunately I cant really add another step as I've got a 3d scanning booth spitting out objects from fusion to me, to use in the visuals (anaglyph, for a 3d party at a film festival) and fusion gives the best models in the quickest time! I'll just have to live with facets I suppose!

blackburst's picture
Re: Model Not Smooth in K3d 1.8

I've had this with several versions of k3d, with fleeting consistency. I know that any 3d object "effects"(twist, quantize, gravity etc) need to be bypassed in order for smooth to work, even if they're not "doing" anything. Also I have even noticed that stopping and starting rendering in the viewer has made it come good. Hopefully you get it sorted :)

cat's picture
Re: Model Not Smooth in K3d 1.8

I finally tried running it in vdmx, and it was too crashy for words, so redid it last minute in vvvv, although I did miss some things I had going in my qc patch, it all worked out ok! Heres some pictures I've made from the scans in vvvv http://www.flickr.com/photos/94556798@N05/sets/72157633139873391/

khenkel's picture
Re: Model Not Smooth in K3d 1.8

As Chris mentioned, smoothing requires a simplified model. You can do this by checking the simplify toggle in the object loader and selecting smooth normals in the renderer patch (note that you'll need to stop and restart the composition in order for these changes to take effect).

I noticed that the em.obj model already had averaged normals, and that loading the model using the default settings did preserve those values (with pass-through normals set). However, if smooth is toggled in the 3D Object Loader without simplify also being checked, Kineme3D will recalculate the normals in preparation for averaging shared vertex normals (overwriting the imported normals). Since the object is not simplified, no shared vertices exist, and the faces are left facetized.

cat's picture
Re: Model Not Smooth in K3d 1.8

Ah! Thats much better, thank you for your clear explanation!