Videotools 2.3

spendergrass's picture

Hi, I am truly sorry to be annoying. I know that the Kineme team is working on Vuo and is too busy to fully support plugins. But I need an answer to this question so I'm going to try one more time. Hopefully someone out there knows.

It's no secret that videotools 2.3 has some issues. http://kineme.net/node/11641 But Kineme did release it so it must've worked for them when they built it. That leads me to believe that there is hope. I have personally tried the following setups, but haven't tested all possible combinations.

OS 10.6, 10.7, 10.8

Blackmagic Decklink Duo and HD Extreme 3

Drivers 9.0-9.7.5

Quartz 4.0 (103.1) Framework 4.2 (156.30)

Quartz 32bit and 64bit

Nothing so far has worked. No matter what I try, the Blackmagic plugin always crashes Quartz.

Thank you very much, Sam

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

gtoledo3's picture
Re: Videotools 2.3

I have it working in the context of an application I develop that runs a qtz that loads that patch.

What has come up in 10.8, for me, is that for some reason a crash will happen if the regular video patch and the black magic patch are loaded in the same composition. Maybe there are different issues as well.

spendergrass's picture
Re: Videotools 2.3

Thanks for replying.

If I understand correctly, you've developed an application that loads a composition? Does the BM plugin work in Quartz Composer? QC crashes on me if I connect a Blackmagic and Billboard plugin.

Would you mind telling me which Blackmagic card you are using and which driver version you're using?

Thanks, Sam

gtoledo3's picture
Re: Videotools 2.3

I don't have a setup that lets me monitor it on 10.8 because the tower I have won't load 10.8... That said, I'm certain I've seen it working in 10.8, in QC editor, on multiple towers.

So, I just setup the composition/app - it runs OK without the black magic hardware installed - and some techs are actually using it on the road with the black magic. I'll try to find out what seems to be working.

jrs's picture
Re: Videotools 2.3

I just commissioned the fix's to the black magic capture along with a few extra features (multi card input) and can say it all works great....Smorkis Rocks

Things should be released soon

gtoledo3's picture
Re: Videotools 2.3

If you can-

Test it with the queue object, test it into a shader, test flipping the input settings while running, test with multiple instances of the patch in the same qtz, and test with it and the video patch co-existing. Those are all of the areas of questionable performance I've encountered.

jrs's picture
Re: Videotools 2.3

I can't test until I'm back at work on Monday but I can say multiple patches work, I've had 3 intensity pro's working and also an intensity and a declink quad. You can also change the input res and input type (sdi/hdmi etc) on the fly and it works fine as does hot plugging new inputs.

I'll try the shader and queue next week but I suspect they will be fine.

gtoledo3's picture
Re: Videotools 2.3

Sweet... I'd guess they will be too, since I've mentioned it to kineme before.

spendergrass's picture
Re: Videotools 2.3

Thank you so much. Looking forward to it!

stuart's picture
Re: Videotools 2.3

I've tested it with a card and my Thunderbolt box, both working great so far. I'm glad to hear it supports multiple inputs as well. The original one I commissioned worked great in 10.6, was a little dodgy in 10.8, but this one seems to sort out all the dodgyness ;-)

jrs's picture
Re: Videotools 2.3

Thanks for the original commission Stuart, and based on the fact that bm input stopped working in the standard qc video input patch under 10.8 I'd bet that dodgyness was most certainly a result of apple and bm's changes not kineme. I should also probably note that its not me but www.igloovision.com that people should thank (along with smorkis) for the changes and new functionality.

gtoledo3's picture
Re: Videotools 2.3

Also, remembered this morning that my comments about it working in 10.8 weren't necessarily based mainly on the most recent version.