Kineme3D - latest release

cybero's picture

Fantastic, a truly 10.6.x conformant, in my working experience, release of Kineme 3D.

It doesn't spit its dummy out, it renders well in Quartz Crystal.

Even structure_explode takes less than 2 minutes for a 10 second clip in Quartz Crystal.

I think I'll create a little demo album just in honour of this release on YouTube - so good.

Hope you don't mind an unofficial video release GT :-) - as yours did render well - you'll get tagged :-) [ or removed from album if you so wish it]

I'm still to see just what the Open Asset Import support will extend to, pretty thrilled that .dae render from file path works AOK now.

The little .md2 animations even work in Quartz Crystal - brilliant.

Cheers.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Scratchpole's picture
Re: Kineme3D, v1.3 beta (20100307)

Tried to load up a boid particle composition based upon the fish example and got this exception: *** -[Kineme3DRenderer render]: unrecognized selector sent to instance 0x1800a050

Tried original boidfish example: no go. Stops viewer window rendering correctly. black and white checkerboard.

OS 10.5.6 MacBookPro 4,1 GeForce 8600M GT

Do you need more?

EDIT: I think it's a known particle tools bug! That'll teach me to read the bug reports. But I'm on particle tools 0.3 and the latest beta of K3D??

EDIT TWO: moved this to bug reports sorry for double post.

cybero's picture
Re: Kineme3D, v1.3 beta (20100307)

I also have been finding combining 3d Kineme with Particles Kineme to be a trifle difficult, though not entirely impossible.

It isn't specifically a 3D bug, but rather a bug with Particle Tools and 10.6.x and possibly some other stuff I'm unaware of.

Fish.md2 isn't very animated - always thought the best place for a fish was on a dish :-).

See attached Kineme3D example - come to think of it a publish to project folder option that would bundle up required resources would be a lovely touch on the KinemeCore front, know it's not asking much •~, well no more than asking for 64 bit update to Particle Tools.

Any chance of that happening. BTW?

Chuffed to bits about the 3D update and latest GL Tools - sweet.

The boid fish in 32 bit QC 4 results in

0x9381827d: -[QCContext renderPatch:time:arguments:]
0x93817f9c: -[QCGraphicsContext renderPatch:time:arguments:]
0x93816f53: -[QCOpenGLContext renderPatch:time:arguments:]
0x93816d16: -[QCPatch(Runtime) render:arguments:]
0x0000f4e1
0x93857e56: -[QCView render:arguments:]
0x93882af7: -[QCView _renderTimer]
0x9385d3b2: _TimerCallback
0x91377edb: __CFRunLoopRun
0x91375864: CFRunLoopRunSpecific
0x91375691: CFRunLoopRunInMode
0x98bd6f0c: RunCurrentEventLoopInMode
0x98bd6cc3: ReceiveNextEventCommon
0x98bd6b48: BlockUntilNextEventMatchingListInMode
0x95474ac5: _DPSNextEvent
0x95474306: -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
0x9543649f: -[NSApplication run]
PreviewAttachmentSize
md2-kineme3d.zip501.23 KB

gtoledo3's picture
Re: Kineme3D - latest release

No, with the new version of K3D in combo with Particle Tools, making particles that are 3D objects doesn't work correctly... I think it's an issue with Particle Tools.

You can take the output of a scene, use a structure:render patch, and iterate the structure output. Use the classic structure index/interpolate setup, to place any object, 3d or even other render patches, where the particles would be as a sort of work around.

The method is pretty effective for with Particle Tools in many instances, to use the x/y/z info to place other render patches...the boidfish ends up with a kind of slower frame rate though.

See the attachment.

PreviewAttachmentSize
Particle Tools Iteration Placement.zip512.17 KB

cybero's picture
Re: Kineme3D - latest release

That works really nicely in 32 bit mode in QC 4. Brilliant workaround.

Have you had a chance to try out the Open Asset Import facilities, thus far I can get .lwo, .md2 but not .md3, .ply - great news for MeshLab users **:-), .3ds, and .obj. working

.max, .irrmesh, .stl, .fbx. ac, .fbx and .dxf are all no show on the render stage IMETD.

I still have to try out running structured 3d objects on the currently successful formats and double checking on the unsuccessful ones.

smokris's picture
Re: Kineme3D - latest release

.max --- OAI doesn't handle this format at all (it's a complex procedural format, unlike the rest which are predominantly poly soup)

.irrmesh, .stl, .fbx, .dxf, .ac, .md3 --- K3D renders all the meshes I've tested in these formats. Please attach here or email me meshes that don't work.

cybero's picture
Re: Kineme3D - latest release

Sure, will do, expect some update on that later today.

I hasten to add, I am aware from my experience to date, that not all examples of any given file extension will render properly.

BTW , when you refer to these other file formats rendering AOK, are these being rendered as structured objects or just simply as an object - the latter being my current testing mode.

cybero's picture
Re: Kineme3D - latest release

OK .max was not on the OAI list [my bad, don't know where I got that idea from - wishful thinking probably :-)] and the .irrmesh I now have working examples, so too with .fbx,.md3 , .stl & .ac, all of which now work; .dxf, however, seems to defy any attempts to get what looks like well formatted .dxf files to render at all.

If you want I could attach the failing examples of file formats that success has been achieved with some other examples of, but I'll just limit myself presently to uploading just a zip archive of the several .dxf files that are not working at all.

All of these attached just crash QC 4.0 [32 or 64 bit mode] - without fail •~

BTW - still stoked over the new Kineme3D release.

Also, given that the successful file formats are the same files that were crashing yesterday, I think a whole lot of this 'IMETD' results were down to my running QC 4.0 with cache related problems causing loader failures, otherwise, why would those same files, on a fresh session, work AOK today?

PreviewAttachmentSize
dxfnoshowinkineme3d.zip22.33 KB

smokris's picture
Re: Kineme3D - latest release

I've been testing using 3D Object Structure Renderer, but both that and the normal 3D Object Renderer use the same underlying functionality.

As for the DXFs: one of them contains only 2d data, and the other three contain only lines (no polygons), so there's nothing for Kineme3D to load. Fixed the crash in the latest beta (but it still doesn't load 2d geometry or non-poly geometry).

gtoledo3's picture
Re: Kineme3D - latest release

Maybe this is the wrong place (?), but an over-riding thought I've had since using the structure render, is that there really should be structure warps for the other types of deformers as well. I may have already mentioned this.

gtoledo3's picture
Re: Kineme3D - latest release

What does "spit it's dummy out" mean?

Oh yeah, I don't mind that vid post btw Cybero, totally cool.

cybero's picture
Re: Kineme3D - latest release

'spit it's dummy out' - usually a GF Log message , at least , or worse, when speaking of QC, [ can also be used to apply to all and any type of technical failures :-) ].

cybero's picture
Re: Kineme3D - latest release

That structure explode patch has a whole load of tweakable settings, love the Chaos :-). Loves objects - though there have to be objects, or it can just say no, in effect.

Apologies for the dxf confusion on my side - still having problems with these as it happens, no doubt in no small part down to the contents and formatting of the files presented by me.

I am using .dxf downloaded from Honda Official Models, they have them as .lwo and .dxf, they even have a fully fledged robot - sweet.

Presenting a an object to a 3D Object Renderer is successful with .lwo models but not with the .dxf version of the same model part.

[edit - I don't believe it , but the honda dxf lack normals, just vertices- so same lack of poly mesh - perhaps I can rectify this sort of problem in Mesh Lab - do a proper pre flight check on that file format seeing as how its so capable of modelling up without information that the the 3D Renderering patches need]

[final edit - success - finally got the problem ironed out - needed some editing, adding in of feature sets in the dxf - pbourke has a very useful site - seen mentioned here before for a plain explanation of dxf fundamentals, amongst a host of other useful graphics programming information]

The 3D Structure Renderer likes some structures better than others and seems otherwise to be fairly well file format agnostic, although it seems, subjectively, IMETD, to possibly prefer obj file format structures.

cybero's picture
Re: Kineme3D - latest release

See DXF Structure Explode.

Problem [pbck derived] sorted out.