Hiroaki Applescript Patch

steve holmes's picture

I just downloaded the Hiroaki Applescript Patch ( http://hiroaki.jp/index.php?Quartz%20Composer%2FCustom%20Patches#content... ) and compiled it in xcode but I can't seem to get it to work. I have tried pointing the patch to an applescript file to run, I have also taken the contents of a script and put it in the patch, neither of these way make the patch run, I was wondering if anyone else had had any success with this patch. Cheers Steve


cybero's picture
Re: Hiroaki Applescript Patch

I also downloaded and sought to compile the plug in. The build succeeded with a warning:-

Building target “AppleScriptPatch” of project “AppleScriptPatch” with configuration “Debug” — (1 warning)
       cd /Users/cybero/Desktop/AppleScriptPatch
    /Developer/usr/bin/gcc-4.0 -x objective-c -arch ppc -fmessage-length=0 -pipe -Wno-trigraphs -fpascal-strings -fasm-blocks -O0 -Wreturn-type -Wunused-variable -isysroot /Developer/SDKs/MacOSX10.4u.sdk -mfix-and-continue -mtune=G5 -mmacosx-version-min=10.4 -gdwarf-2 -I/Users/cybero/Desktop/AppleScriptPatch/build/AppleScriptPatch.build/Debug/AppleScriptPatch.build/AppleScriptPatch.hmap -F/Users/cybero/Desktop/AppleScriptPatch/build/Debug -F/Developer/SDKs/MacOSX10.4u.sdk/System/Library/Frameworks/Quartz.framework/Frameworks -I/Users/cybero/Desktop/AppleScriptPatch/build/Debug/include -I/Users/cybero/Desktop/AppleScriptPatch/build/AppleScriptPatch.build/Debug/AppleScriptPatch.build/DerivedSources -include /var/folders/aU/aU7YNR3jFKGkLcMcRkWQsk+++TI/-Caches-/com.apple.Xcode.501/SharedPrecompiledHeaders/AppleScriptPatch_Prefix-hlescawyesbqyodvnuxfdzkrhtic/AppleScriptPatch_Prefix.pch -c /Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m -o /Users/cybero/Desktop/AppleScriptPatch/build/AppleScriptPatch.build/Debug/AppleScriptPatch.build/Objects-normal/ppc/AppleScriptPatchLoader.o
/Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m: In function '+[AppleScriptPatchLoader registerNodesWithManager:]':
/Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m:15: warning: no '-registerNodeWithClass:' method found
/Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m:15: warning: (Messages without a matching method signature
/Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m:15: warning: will be assumed to return 'id' and accept
/Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m:15: warning: '...' as arguments.)
      /Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m:15: warning: no '-registerNodeWithClass:' method found
/Users/cybero/Desktop/AppleScriptPatch/AppleScriptPatchLoader.m:15: warning: (Messages without a matching method signature
Build succeeded (1 warning)

Then I tried the binary version of the plugin which can be obtained from the same site holding the patch project.

This does actually work after a fashion, so I guess that the problem is in the code as evidenced by the XCode build results I got.

Sadly, there is little or no documentation for this patch and no example composition that I can find. Perhaps we ought to just drop Hirokai a line and see if this is a plugin problem he knew about.

Shall tell you more later about running Apple Script variables through the patch, but for now, I might suggest thast you download Apple Script Patch Universal Binary version from Hirokai's Playing Field site and start experimenting with the same item yourself.

Have fun:-)



Hirokai kindly responded to a recent email enquiry I made of him regarding this 3rd party patch, the follwing is a direct quote confirming the non-Leopard compatability of the currently available version.


Thanks for your mail. The Apple Script patch was built for Mac OS X 10.4.x. So the patch might not be able to run on 10.5.x (Leopard).

Now I do not have spare time to re-build it for Leopard, but please wait. I will re-build it for Leopard soon. At that time, I will tell you.

Oh and just to echo a question from Hirokai - what were you thinking of using the Apple Script patch for?

Anyhow hopes this update to this reply to your original post actually helps to clarify matters for you.

buildresult.jpg150.31 KB