Can't load Billboard, sprite or any other renderer patch into QC under Lion.

lifemusic's picture

I recently upgraded to Lion and am now using QC for the first time since the upgrade. When I try to drag a Billboard (or any other renderer patch) into the composition from the Library , nothing happens. There is no crash or error massage from the program, but the composition remains empty. Is this known problem with Lion ?

Perhaps related, my QC is 4.0, whereas I see discussion her about QC 4.5. It apparently was not installed when I did the update to Lion. Will QC 4.5 solve the problem? How do I get it?



lifemusic's picture
Re: Can't load Billboard, sprite or any other renderer patch ...

I found the download for "graphics tools for developers March 2012" at Apple Dev site. It isn;t included any more with the Xcode download. I'll try that to get QC 4.5 and see if it fixes the problem.

Well, I've now got QC 4.6 on my system, but it hasn't solved the strange problem with render patches. Any ideas?

thanks Bruno

cybero's picture
Re: Can't load Billboard, sprite or any other renderer patch ...

If you've updated your Xcode and your Graphics Tools then QC should run AOK.

Have you also updated your installation of Lion to the most up to date version?

Your QuartzComposer.framework should be version 5.0.

Sounds like your installation is missing something prerequisite.

gtoledo3's picture
Re: Can't load Billboard, sprite or any other renderer patch ...

There are three Graphics folders on your system, one at the System level, one in /Library (that encompasses the scope of all users), and then one at ~/Library (the user scope). The one at ~/Library will be hidden in Lion+ by default, but you can access it by holding option while browsing the Go option in Finder.

You need to go into each of those places and make sure you don't have really old plugins, conflicting plugins, or plugins that have had a migrate but that have possibly lost their authentications.

"System" should never have anything non-Apple in it.

/Library and ~/Library may have some Apple patches in them. Be careful, and try not to remove those. That said, you can just grab each of the three Graphics folders, place then in some folders somewhere else temporarily, and try starting QC, and see if stuff works.

Then, you may also need to go into the user Cache folder, as well as the user Preferences folder, and delete cache and preference files that are associated with Quartz Composer or Quartz Composer Editor.

I know someone that this happened to, and I'm pretty sure that's what wound up solving their problems. I'm uncertain whether it was a plugin issue (there were definitely issues) or the deleting of the cache/preferences that did it, because there wasn't critical testing just trying to get it working quickly.

Also, on at least 10.7.0~10.7.4, Quartz Composer and the SL era Developer folder should be able to work in Lion if they got there through a migration. I have one partition that's an up to date Lion install, and then another one that uses the old Developer Tools, and both work fine. Take it with a grain of salt, but unless you're doing stuff with appstore and need that stuff, you can work w/ Xcode 3.2.x in Lion. It will use all of the newer framework versions, etc.

lifemusic's picture
Re: Can't load Billboard, sprite or any other renderer patch ...

Thanks George - I trashed the old Kineme AlphaChannel plugin that was hiding in my ~/Library/Graphics folder. That's fixed it. - bruno