soundflower for lion

dust's picture

if you use soundflower and have upgraded to lion, you will notice there is some serious distortion. so i have made a build of soundflower and soundflowerbed that works with lion.

sunflower requires some specific user permissions that Xcode doesn't handle so you will have to run the build script.

• remove soundflower with apple script. • open terminal and build

$ cd /sound_flower_lion_1.5.3/Tools
$ ./build.rb --dep
$ "enter password"

• restart computer • run soundflowerbed • choose soundflower in audio list

this is only for 10.7 - 32/64bit machines


sound_flower_lion_1.5.3.zip444.02 KB

harrisonpault's picture
Re: soundflower for lion


I see that cycling74 has noted this distortion problem with Max and promises a bug fix for lion. Hopefully they will provide an "official" fix for Soundflower and their other software soon.

Graapho's picture
Re: soundflower for lion


When trying to build this (./build.rb --dep) I get the following error: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/pathname.rb:263: warning: `*' interpreted as argument prefix

I have not changed the default ruby installation as far as I know, so I'm on "vanilla" 1.8.7. I did change the pathname.rb enough to get rid of the error, but I still got the 'BUILD FAILED' message.

Also, I removed all traces of old soundflower files, both by running your script and removing files manually.

Do you know what may cause this?


dust's picture
Re: soundflower for lion

not sure i got that warning but the build still went fine... i wouldn't start removing things manually. the apple script removes old soundflower. do that first. then the build script removes things and puts them back with proper permissions by checking log files.

not sure what that warning is talking about I'm not a ruby person. seems to work with any argument prefix... maybe * is to build both dev and dep. $ ./build.rb *dep $ ./build.rb -dep $ ./build.rb --dep $ ./build.rb dep

i set the Xcode file to build for deployment.... you could try... $ ./build.rb just make your development settings are compilable to lion...

here are some more explicit instructions for building 10.7 64bit only. i'm assuming you haven't hacked some lion build to run 32bit i386.... see attached for pictures of settings and my build project. remember to restart your computer.

$ cd Desktop
$ mkdir soundflower
$ cd soundflower
$ svn checkout
$ cd trunk/Source
$ open Soundflower.xcodeconfig
   SDKROOT[arch=x86_64] = /Developer/SDKs/MacOSX10.7.sdk
   GCC_VERSION[arch=x86_64] = 4.2
$ open Soundflower.xcodeproj
now edit build settings for project your build set up should be fine you just changed that….
• architecture • base SDK

• change compiler

• edit scheme Product > edit scheme set to deployment

• now run the project to make sure it will compile….

you should get that one warning…. it is asking to modernize your project. forget about it…
$ open /Tools/Uninstall Soundflower.scpt 
•run unistaller

$ cd /soundflower/trunk/Tools
$ ./build.rb --dep
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/pathname.rb:263: warning: `*' interpreted as argument prefix
Building the new Soundflower.kext with Xcode
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/pathname.rb:263: warning: `*' interpreted as argument prefix
Notice: -print-diagnostics (-t) ignored; use kextutil(8) to test kexts.
Requesting load of /System/Library/Extensions/Soundflower.kext.
/System/Library/Extensions/Soundflower.kext failed to load - (libkern/kext) different version/uuid already loaded; check the system/kernel logs for errors or try kextutil(8).
Unloading and removing existing Soundflower.kext
Copying to /System/Library/Extensions and loading kext
soundflower.pdf.zip241.07 KB
soundflower.zip4.6 MB

Graapho's picture
Re: soundflower for lion

Just did a clean install of Lion, and still got the exact same error. Guess I'll do with jackosx until I find a packaged installer that works with lion.

Thanks a lot regardless!

dust's picture
Re: soundflower for lion

thats interesting. i will have to try on my fresh lion install. the computer i tested this with i have been migrating for a few years or well since leopard. been meaning to fresh and clean install. will try it on another machine and report back

cybero's picture
Re: soundflower for lion

Well all my Lion | Soundflower woes are over for now :-)

The workaround?

I successfully installed a now fully functional Soundflower .kext extension by using the Kext Utility. I picked the version Iused up from Don't know who runs that domain and assets, but cheers fellow Mac user for that.


Open up your Soundflower folder, I used the .kext from within the soundflower download posted by dust above this post or two, the second posting, BTW, if that makes any difference.

Highlight and select the .kext extension, drag and drop onto the Kext Utility and hey presto, .kext installed and the two [2 & 16 channel] Soundflower options are available where I need them and nil distortion upon the sound.

Needed this installed to facilitate a newly acquired copy of [Screenium.

& am only just about getting ready to do some serious recording with that application.

I had tried aforehand with installing Soundflower with your Lion focussed distro, dust, but the results where less than satisfactory, clicks and stuff all over the show - like a baby needing burping, now the sound quality is as smooth as a baby's bottom :-).

BTW, I found the tip that saved my Soundflower dependency situation regarding the use of the .kext utility on the cycling ' 74 forum site.

Have posted this also to Screenium's authors, haven't registered to their forum as yet, so didn't know if they knew already, [which they probably do, but just in case •~]

dust's picture
Re: soundflower for lion

cool yeah screen recording apps are sometimes a good source to find modified sound flower builds. usually inside the apps resources folder you will find a installer for sound flower.

john's picture
Re: soundflower for lion

Just installed 10.7.1 everything works again.

Zirafkend's picture
Re: soundflower for lion

awesome explanations it has worked like a charm.

No more frustrations ;) THXX

chjan's picture
Re: soundflower for lion

We had some users of SoundPimp reporting problems with SoundFlower installation, however we had no problems with SoundFlower on Lion after a recent upgrade. However since other do, see as we keep a post updated until this problem has been solved.


dvhasselt's picture
Re: soundflower for lion

I had some issues building this on 10.7.2. If I printed the stderr output I got the following error (which didn't make any sense to me):

2012-03-04 14:56 xcodebuild[1864] (CarbonCore.framework) FSEventStreamFlushSync(): failed assertion '(SInt64)last_id > 0LL'

I was also unable to use load.rb to install the Soundflower.kext which came prebuilt with the download. After running kextutil it appeared to be some wrong permissions. After fixing those I could successfully install the prebuilt kext with load.rb.

To fix permissions:

sudo chown -R root Soundflower.kext/
sudo chgrp -R wheel Soundflower.kext/

I have yet to test this build extensively but I haven't heard any glitches or stalls yet, even with a buffer size of 64. Usually it started glitching and stuttering after a minute of 2.