Origami not installing correctly? Quartz Composer (OS X, El Capitan)

buckmilder's picture

Hey guys,

New to QC here. I'm trying to install Facebook's Origami for QC. I've followed the steps here: http://facebook.github.io/origami/download/

After it tells me that Origami has successfully installed, I open Quartz Composer (I put QC in my applications folder) for a new Basic Composition. I'm looking for the 'Phone' patch in the Library window but nothing comes up when I search in the filter.

When I go to Go/Library/Graphics/, there is a 'Quartz Composer Patches' folder that contains Origami (folder) and Origami.plugin (there is nothing else in my Graphics folder).

I've tried reinstalling, restarting my computer, following YouTube video tutorials (on just how to INSTALL it) to no avail. I've tried this on my work computer and personal laptop. I can't seem to find anything on the web about this issue - I'm not sure if anyone else has even had an issue with this! Is there something I'm missing here? Any insight would be great!


Achim Breidenbach's picture
Re: Origami not installing correctly? Quartz Composer (OS X, ...

Hi Buckmilder!

I guess questions about Origami are better placed here:


However, two suggestions:

1) Look into the "Console" app when opening QC. QC is reporting if and why a certain plugin can't be loaded. 2) Check if your QC-Editor is set to 64 bit mode (Finder -> select QC-app -> press command-I) or if it runs in 32 bit mode. Maybe Origami is 64 bit only?



buckmilder's picture
Re: Origami not installing correctly? Quartz Composer (OS X, ...


Thanks for the suggestions. I'll try it and post on fb group if need be.

I did notice that if I drag a file into the preview window, it will show up. For example, if I drag the phone.qtz file into the work station, the graphic will populate the screen and a node will pop up as well - is this an legitimate work around? Just wouldn't want to begin working this way if it'll cause a ton of headache later.

Cheers, buck