Midi input- Stumped

DataFlow's picture

I have been trying to put together some audio/visual experiments with Ableton and QC. I have been able to get all my other programs to talk nice over the IAC but i can't figure out what the deal is in QC. I tried the normal midi patches-no input. tried the Kineme patches- no input. I know that there is midi coming out, I have tested it it with Pure Data and Arkaos Grand VJ. Any suggestions?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

itsthejayj's picture
Re: Midi input- Stumped

Try changing the MIDI note patch down 2 octaves (or is it up *soz forgotten) e.g. if your sending a C5 note qc will receive it as a C3 note. This isn't a bug funny enough but different conformities qc follows.

Otherwise have you tried sending a midi cc or note to Ableton to see if your IAC driver is sent up right?

Do you have the right channel selected?

DataFlow's picture
Re: Midi input- Stumped

Well I have not tried the note value down, i will try at.

I am getting midi in to Pure Data just fine over the IAC, it recognizes channel number, note number, and velocity, so its good for debugging this kind of thing.

Hopfeully your suggestion will work, Thanks!

gtoledo3's picture
Re: Midi input- Stumped

Do you have your Viewer window in "play" when you are doing this? I'm sorry if that's a basic one for you, and I'm needlessly pointing that out. Remember that your midi has to be pumping to some kind of render patch (a sphere, or cube or whatever) and your Viewer window has to be in play mode for anything to start evaluating.

info4's picture
Re: Midi input Note Bug

All the time I thought midi note receiver patch of QC doesn't works. But you're right. If Ableton sends C2 , QC gets C4. There is a difference of two octaves. I tried with IAC Port and it worked!

photonal's picture
Re: Midi input Note Bug

To get MIDI from Ableton to QC, I just physically do it via a midi cable: set the destination port in Ableton and cable this with your midi interface (assuming you have one) back to a free port for QC to access. (And don't forget to 'learn' the data in the QC midi patch)

sbn..'s picture
Re: Midi input Note Bug

Whoa, that sounds like a hassle. Have you had trouble using just the IAC, or what prompted you to do this?

I'm just curious...

photonal's picture
Re: Midi input Note Bug

Actually, this seemed the easiest way to patch the midi data :)

To be honest, I've never tried the IAC functionality - maybe I'll look into using it!