QC plugins on Leopard Installation

stevensmith's picture

Hi,

I'm kind of loosing patience here! I simple can't load the kineme patches on Leopard.

I've tried copying them in "/Library/Graphics/Patches/", /Library/Graphics/Quartz Composer Patches/" and /Library/Graphics/Quartz Composer Plugins/" and nothing works.

What am I doing wrong? I need to use Global MIDI Output CC but simply can't get it started!

Attached is the error message I get all the time and my file structure.

Also, I don't know if it changes anything but my leopard is in French so I actually install it in ""Bibliotheque/..."

Thanks for the help. Steven

PreviewAttachmentSize
Image 1.png
Image 1.png63.01 KB
Image 2.png
Image 2.png75.5 KB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cwright's picture
orig kineme plugin

The Original kineme plugins were Tiger-only. If you'd like, I can spend a day or two updating many of them to work on Leopard for you.

The unusual directory might be throwing it off too... have you had any plugins work at this point? if not, you'll need to put them in "/Lib../Graph../Quartz Composer Patches/" or, preferably, "~/Lib../Graph../Quartz Composer Patches/". These are the only places QC will load them from automatically.

stevensmith's picture
I don't think the problem is

I don't think the problem is with the directory name because when I try to create the folder "Library" it says that the folder already exists.

I suppose that Mac translates the folder names but keeps a reference in English to point to the right folder when called upon.

You say you can spend 1 or two days updating them for me... I would greatly appreciate it. Would it save you time if you could only update the Global Midi Output CC plugin?

Thanks a lot You're a life saver!

cwright's picture
I'll see what I can do

I've done some work translating the midi patches for Leopard already, so it shouldn't take long. Check later tonight or tomorrow for a beta midi patch for leopard :)

Just to confirm that it's not the directory, can you see if any other plugins show up in the patch creator? I've never seen such a setup, so it would be good to know if QC does handle it nicely for sure. I'd guess it does, but I don't know.

stevensmith's picture
Other plugins work

I've installed 2 plugins from Sam Kass' website and they load/work properly in Leopard. (link: http://www.samkass.com/blog/page2/page2.html)

He also says: "Note this is only compatible with the Quartz Composer found on the Leopard developers install."

I also found out that they need to be placed in the default folder "Library/Graphics/Quartz Composer Plug-Ins" in order for them to work.

When I copied them to a folder called "Patches" they didn't load.

Attached is a screenshot of the plugins and my file structure.

PS: I couldn't load any of the plugins downloaded from Kineme

Again, THANKS!

PreviewAttachmentSize
plugins.png
plugins.png155.92 KB

cwright's picture
PlugIns vs. Patches.

Sam Kass's plugins use the Official QC API (note the "Plug-In" category name), so they should go in "Quartz Composer Plug-Ins". Most of our plugins use the Unofficial QC API, so they need to go in "Quartz Composer Patches".

It's interesting that they're not loading. Can you try putting them in your User directory's "Library/Graphics/Quartz Composer Patches/" folder (create it if it doesn't exist)? If none of them are loading, we've got to take care of that as well.

stevensmith's picture
New Error

Patches still don't load.

I get this error when I open QC (see attached image)

PreviewAttachmentSize
error.png
error.png48.51 KB

cwright's picture
Right place!

Yay! that means they're getting loaded! Of course, the error is because that's a Tiger-only plugin on Leopard, but wherever you put them, that's where they need to go :)

stevensmith's picture
In case it helps, I get the

In case it helps, I get the same error if I put the folder "Quartz Composer Patches" in the user directory or in the main library folder.

What now?

cwright's picture
remove the tiger-only patches

That error can't be fixed by moving stuff; it needs an updated version of the plugin. ImageDownloader is currently Tiger-only, so you can't use it. A few others are Tiger only as well. The error dialog will tell you what plugin it's not able to use, so you can just remove the ones it doesn't like.

we do need a better way to tell which plugins are for which version...

stevensmith's picture
Sweet!

I removed the ImageDownloader plugin and most of them work.

I can now work with Global MIDI out CC and the 3 others MIDI.

Thanks alot. If you need me to test some stuff out, just ask!

stevensmith's picture
Spoke too fast

Actually, they don't work.

When I deleted the ImageDownloader, the rest showed up in the patch library but when I try to use MIDI Global Out CC it doesn't work because it sees it as an empty macropatch.

Anything I can do?

cwright's picture
wait

At this point, all you can do is wait for the leopard beta. don't worry, it'll be soon.

psonice's picture
"How to install" page

I just spent an hour trying to get the plugins to load too. Same mistake - I was putting them in plugins, not patches. Having checked, the installation page is actually correct, but it could save other idiots like me some time if the word 'patches' was in bold :)

cwright's picture
Oops

Sorry about that. I'll make the change. Thanks for the idea :)

NYDave's picture
Midi Patches updated for Leopard?

Wondering if these were ever updated and posted. I've been searching and haven't found them. Thanks!

C4C Center for Community Weblog: The Daily Glyph

cwright's picture
miditools

They're in beta still, called MidiTools or something similar now -- check the beta page. There are some rough edges still -- not many midi users hang out here to iron them all out.