Quartz Composer crashes with KinemeCore

quantaoflove's picture

Hi. If I put KinemeCore.plugin in Library/Graphics/Quartz Composer Patches/ Then my quartz composer does not work properly anymore. I get an exception right as I open it, with no backtrace, the same when I try to close it, and it never quits so I need to do force quit.

I'm using os x 10.6 and QC 4.0. I downloaded KinemeCore 0.4. I don't have any other plugins.

Any suggestions? Thanks.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

cybero's picture
Re: Quartz Composer crashes with KinemeCore

Remove Kineme core and wait for update as it is not SL compatible

cwright's picture
Re: Quartz Composer crashes with KinemeCore

I've actually not been able to reproduce any kinemecore problems in SL since 0.4, so here's what needs to happen:

1) provide your QC editor plist (~/Library/Preferences/com.apple.QuartzComposer.editor.plist)

2) provide your kinemeCore plist (~/Library/Preferences/net.kineme.KinemeCore.plist)

3) provide some configuration information (32/64 bit mode, any particular composition you're opening at the start, etc.).

So far, we've had maybe 3-6 people state this problem, but exactly zero have supplied any information more pertinent than "It's broken!", which is exceedingly unhelpful, unfortunately :/ When we cannot reproduce an error, we're unable to see what's causing it, which then makes us unable to address it... So getting a setup that's as close to yours as possible increases our chances of reproducing the bug on our own machines. Then we can start the exciting process of finding out what's causing it, and then, ultimately, how to fix it.

offonoll's picture
Re: Quartz Composer crashes with KinemeCore

Hi Chris! I have exaclly this problem with kineme core. It worked at the begining but now, keneme core prefs don't even show up and on edition window doesn't show the menue eather. I do remember that I was activating actions from prefs K.core when I could see it but then it crashed. I kind of remember that i wanted a smaller scrolls and I might activate some more things and ... now I just open QC with your lates beta and I got this exceptions was release:

0x88262fb6: -[NSApplication _doOpenUntitled]
0x8826291b: -[NSApplication(NSAppleEventHandling) _handleAEOpen:]
0x882625b9: -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:]
0x803291d2: -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:]
0x80329002: _NSAppleEventManagerGenericHandler
0x869be176: aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*)
0x869be06f: dispatchEventAndSendReply(AEDesc const*, AEDesc*)
0x869bdf79: aeProcessAppleEvent
0x81b48a7d: AEProcessAppleEvent
0x88167707: _DPSNextEvent
0x88166e89: -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
0x8812ca7d: -[NSApplication run]
0x00001d2b

Why are my prefs saved after i delete kineme core patch? If i could delete the patch and star over again with my prefs I could give you more details to reproduce the crash. Thank's

ADDING: Also I got this exception: <No backtrace available>

cybero's picture
Re: Quartz Composer crashes with KinemeCore

I can reproduce that reported problem :-( - ah, well, whatever, I can always place the Kineme Core plugin into the Disabled folder and wait for solution & / or enlightenment about this matter.

I've just sent you the requested information in an email, cwright .

See later post above for clarification of results found that would seem to indicate nil problems with Kineme Core 0.4.

offonoll's picture
Re: Quartz Composer crashes with KinemeCore

ok. I could reproduce the crash after deleting those plist files. Here I attached plist files.

PreviewAttachmentSize
Crash Kineme core plist files.zip1.81 KB

cwright's picture
Re: Quartz Composer crashes with KinemeCore

This is a backtrace -- normally, these are very very helpful. This, however, is one of the cases where they're not (none of that code is our code, so it doesn't tell us what's going wrong in ours).

The preferences are stored in ~/Library/Preferences/ -- com.apple.QuartzComposer.editor.plist for QC itself, and net.kineme.KinemeCore.plist for kineme core. We absolutely need both to reproduce the problem (I can infer that you're using 32bit mode QC because of the backtrace ;)

I have yet to received cybero's email (mentioned below), but please send those along -- there may be multiple ways to trigger the problem, so having some alternatives is helpful.

offonoll's picture
Re: Quartz Composer crashes with KinemeCore

I can reproduce an isolated report, so let's see if we can track the problem 1. delete/move your /com.apple.QuartzComposer.editor.plis and /net.kineme.KinemeCore.plist files. 2. open QC / kineme core prefs and activating the search by cathegories 3. close prefs and QC 4. open it again 5. It will show <No backtrace available> twice and then you click continue. click on view window and it show the exception report I menthion before.

I attached the plist files again if this helps.

PreviewAttachmentSize
Report Kineme core plist files 2.zip1.67 KB

cybero's picture
Re: Quartz Composer crashes with KinemeCore

After deleting the preference files this is what I got upon boot up - see attached picture file, and no Console errors at all.

Seems like that clarifies possibly a major part of the problem, another hangover from transitioning Leopard to Snow Leopard.

So, to formally contradict my earlier response, Kineme Core 0.4 does not seem to have any inherent SL incompatibilities, but does need QC to be given the opportunity to create a fresh set of QC Editor and Kineme Core preferences to work with.

dust's picture
Re: Quartz Composer crashes with KinemeCore

i think that's a point i over looked cybero. loading up qc fresh to create a new .plist then adding in kcore again.

quantaoflove's picture
Re: Quartz Composer crashes with KinemeCore

Hi. I think problem is solved when I cleaned the plists. In fact, I only cleaned the com.QC...*.plist and not kineme core. For reference I attach those plists here. I forgot to copy the kinemecore one before cleaning :( Thanks for the support.

PreviewAttachmentSize
Archive.zip5.25 KB

valentino.lab's picture
Re: Quartz Composer crashes with KinemeCore

hello guys, this problem it happens to me now, i really dont know way? everything was cool until i instaled some _1024 plug ins does anyone know how to fix it? how can i keep using the kineme plug ins?

valentino.lab's picture
Re: Quartz Composer crashes with KinemeCore

i fixed the problem already. The problem is with the imagedifferpatch.plugin when i take it out of the plugin folder quartz comes back to normal.