Does Gifs works on newer versions of QC? Gifs in 3D Cubes.

Fuzuku's picture

Hi. I posted this same thread some time ago in another QC forum and didn't got a way to make it work.

Was wondering if somebody here could do this or had any tip for rendering the Gif to a cube. I'm going to copy and paste the post from the previous Forum. Thanks!

I've been doing some Gifs, and been trying to get them into a 3D cube (one into each horizontal side) with no success at all. (The Gif is set there but with no movement).

Seems that the only "trick" is in the settings of the gif to apply "Extract all images", that's the only constant I've seen.

I tried a couple of easy as 3 steps tutorials, but none have worked so far.

EX:

http://pixelnoizz.wordpress.com/2012/05/18/animated-gif-remixes/

http://www.cogevj.hu/blog/2012/animated-gifs-in-coge-and-quartz-composer/

http://pixelnoizz.files.wordpress.com/2012/05/screen-shot-2012-05-18-at-...

Does anyone has the same problem or has somebody cracked this and has a running composition with Gifs in Sprites, Billboards or Cubes?

Thanks a bunch!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

jersmi's picture
Re: Does Gifs works on newer versions of QC? Gifs in 3D Cubes.

If you extract the frames with an Image Importer, then you can use some type of timebase patch (for ex., Interpolation) to cycle through the images (gif frames) using Structure Index Member after the Image Importer.

Also, you might be able to trick QC into thinking gifs are .mov files by using a Directory Scanner set to scan a folder for images, then feed the structure members to the Movie Location input of a Movie Importer patch. This worked for me in OS 10.7.x. Note that frame rate can be an issue since gifs don't traditionally use fps.

Fuzuku's picture
Re: Does Gifs works on newer versions of QC? Gifs in 3D Cubes.

Thanks jersmi.

I tried the first patch with all connections possible and didn't work for me.

In the first pic (a) I couldn't connect the interpolation result to the front image of the cube, and in both patches from the start the cables would turn red instead of the normal yellow. I am kinda a beginner in QC.

I'll try tomorrow morning the other patch example you placed but if the frame rate is way off, I prefer to find a way for it to work as in the speed of the gifs, because I make them myself and I spend time calculating the exact speed rate for them to work as I expect.

In both patches if the cables are not connected to the expected sources it was because they couldn't be connected. Im running Mountain Lion, I know they have been some issues with QC and Mountain Lion.

PreviewAttachmentSize
Ex a.png
Ex a.png209.82 KB
Ex b.png
Ex b.png151.86 KB

Fuzuku's picture
Re: Does Gifs works on newer versions of QC? Gifs in 3D Cubes.

jersmi wrote:
If you extract the frames with an Image Importer, then you can use some type of timebase patch (for ex., Interpolation) to cycle through the images (gif frames) using Structure Index Member after the Image Importer.

Ok, I understand better what you meant in that patch. Tweaking around I found in the Structure Index Member that changing the index, it changed the gifs images.

So I came up with this simple patch, in the wave generator the amplitude must be set to the number of "pics" the gif is made to and the period I think it must be kept at 1 to maintain original Gif speed. Or near the original speed because its not near the original motion and movement between stills.

I haven't tried or played around too much with it but it works for now, gonna catch myself some sleep ;-) .

If somebody comes up with an improvement patch please post it.

PreviewAttachmentSize
Gif F. Patch.png
Gif F. Patch.png78.51 KB
Wave Generator Inspector.png
Wave Generator Inspector.png26.01 KB
Martian Gun.mov7.39 MB