Plugin Installs

comper's picture

I installed the Kineme plugins in the /Library/Graphics/Patches folder on the root of the system drive and I do not see them in Quartz Composer.. I am running Tiger 10.4. Quartz Composer ver. 2.1.1. I have restarted the computer and still do no see them in QC. The plugins I put in are:

  • AudioVideo-0.2
  • DirectoryScannerBlocking-0.2
  • extract_in_your_Documents_Folder
  • FolderMoviesPatch-0.3
  • ImageWithCompositionPatch-0.3
  • KinemeCore-0.1
  • KinemeQuartzComposerPlugins-0.2
  • LoadUserPluginsFolder-0.1
  • ParticleTools-0.2
  • PBMesh-0.1
  • QuickLook-0.2
  • SnapToGrid-0.1
  • SpeechSynthesisPatch-0.3
  • SpookyPatch-0.2
  • StructureTools-0.1
  • TextFileWriterPatch-0.3
  • TexturePatch-0.5
  • XcodeTemplateForCustomQuartzComposerPatches-tiger-0.5.pkg

I realize some of these plugins are only for leopard. Do I have any listed that cannot be use in Tiger or is there another problem somewhere. I would really like to use these plugins. They seem to be what I'm looking for. Any help is greatly appreciated.

Thanks, Steve

cwright's picture
Re: Plugin Installs

AudioVideo is Leopard only.

Directory Scanner Blocking is probably Leopard Only.

KinemeCore is Leopard Only.

Particle Tools is Leopard Only.

PBMesh is Leopard Only.

QuickLook is Leopard Only.

XcodeTemplate is not a QC Plugin (it's for software developes who want to write custom plugins).

you should REALLY REALLY think long and hard about upgrading -- QC Tiger is essentially 100% deprecated, and we spend exactly 0 time testing our plugins in Tiger anymore. (The only exception is for-pay consulting).

Otherwise, are there any interesting messages in Console?

comper's picture
Re: Plugin Installs

Thanks for your quick response. I'm sure in the near future we will be upgrading to Leopard. I work at a tv station in Cleveland OH. I'm a video editor/compositor. I just recently discovered QC and I think its incredible. I normally use Adobe After Effects for motion graphics but I see huge potential in QC. The station is currently looking into upgrading the traffic system so we'll have to wait a little bit on the Leopard upgrade. Till then if theres anyway to get these plugins to work in Tiger that would be great...especially the Spooky Patch, I could really use it. I did look in Console but there's alot of information there. What should I be looking for in Console?

cwright's picture
Re: Plugin Installs

Cleveland, eh? I don't think our pugins work in cleveland ;)

(Just kidding -- I'm actually in Columbus, and will be driving through Cleveland tomorrow morning on my way to PA for the rest of the week; small world, huh? :)

There's a ton of potential with QC. It's very cool to see what people have accomplished already with it, and new things happen all the time.

In Console, you'll want to look for lines that contain "" or something to that effect -- it'll indicate whether or not it's freaking out on certain plugins (I think). Also, it can't hurt to post screenshots of a Finder window to help us figure out how things are set up on your end.

If all else fails, feel free to e-mail us directly (e-mail at the bottom of each page), and we can privately pass around console logs etc to get you up and running.

comper's picture
Re: Plugin Installs

Ok. I'll do that. I'll let you know what I find out with the Console logs. If I can't make sense out of them I'll email them to you with screenshots. I'm looking forward to using your plugins. Thanks for your time and your help.

comper's picture
Re: Plugin Installs

I did find some information in Console. With the plugins installed I get the following message when I launch QC.

"2009-03-04 10:03:01.058 Quartz Composer[297] Exception raised during posting of notification. Ignored. exception: -[QTVideoInput initWithClass:]: ivar "outputImage" of class "QTVideoInput" is not a subclass of GFPort"

When I delete the plugins Console doesn't display any messages. I am attaching a screenshot of the plugins in finder and the Console messages. Hope this helps to narrow down the problem. Thanks.

Snapshot1.jpg174.03 KB
Snapshot 2.jpg
Snapshot 2.jpg218.45 KB

cwright's picture
Re: Plugin Installs

Ahh, memories :)

Anyway, down to business:

Absolutely Do Not have duplicate plugins installed -- QC Tiger has a bug where duplicate plugins will cause it to hang if they both try to load. All the ones with a "2" at the end need to go.

Delete AudioVideo (your screenshot is whining about this one in particular). Delete KinemeCore (and KinemeCore 2). Delete Particle Tools (and Particle Tools 2). Delete PBMesh. Delete QuickLook. ... the others I'm a bit rusty on.

In fact: remove them all (drop them on the desktop or something), and then add them one at a time, restarting QC each time (you don't need to reboot, just quit QC and start it again). For ones that cause errors, remove them.

comper's picture
Re: Plugin Installs

I'll do that. I'll let you know how it goes. Thanks so much.

comper's picture
Re: Plugin Installs

SUCCESS!!!! I did what you said. I installed the plugins one at a time and found out the offending plugins, just a few, the rest work great. Thanks so much for your help. I did have another question. I'm creating a text generator in QC for Final Cut Pro. I'm using the Image to String patch and I cant seem to get the text to go to the next line with a carriage return in the string input box. The text wraps which is great but the carriage return does not work. Any ideas?

cwright's picture
Re: Plugin Installs

glad that's sorted out. For strings, I'm not sure -- it's been ages since I've used strings in QC-Tiger, so I can't remember the quirks.

There may be some kind of layout control in the inspector panel?

Or are you just not able to actually enter a carriage return in the text area? if that's the problem, you can type the string out in TextEdit, and then copy/paste it in (which preserves CRs)

comper's picture
Re: Plugin Installs

It's the carriage return in the text area. I'll try to dig to see if there's a way to do it. I tried to use javascript to get it to work but was unsuccessfull, but I'm sure theres a way. I'll keep trying.

larrylush's picture
Re: Plugin Installs

Hi I Have tried to no avail following your instructions care fully but Quartz composer refuses to see the PBmesh plug in. I am running snow leopard. QC3.1

Ive put the files in the correct folder but they wont show up...

What on earth am I doing wrong?

Please help.

cybero's picture
Re: Plugin Installs

Hello larrylush,

I think this enquiry really ought to be on separate thread to do with PBMesh in particular, although I can see why you ended up posting here as the plugin didn't show up for you, just like the original postee who commenced this thread in regards of a TV company's workflow system that was, at that time, still running Tiger, a system version which at the time of the postee posting was no longer fully supported except by commission.

I am currently testing the PBMesh plugin in Lion, having installed the plugin into ~/Library/Graphics/Quartz Composer Patches.

You only need to place the plugin into that folder, I say this because you speak of placing files [plural] into that folder. That won't be the source of your problem, but if you have placed anything other than the plugin file in that folder, it is a little untidy for you.

I think that your problem is that you are running QC 3.1 in 10.6, the QC framework for which is 4.0 or higher up to 4.2 and the default installation of Developer Tools for the Snow Leopard distribution is QC 4.0, not 3.1.

I recommend updating your xCode tools, you should find that install in the Optional installs folder of your Mac's install DVD , or if you upgraded a Leopard installation, in the standalone DVD you purchased. That will upgrade both the framework and the application, then both will be singing from the 'hymn sheet' appropriate to their needs.

I think that is what you need to do,larrylush, to rectify what you are doing wrong.

gtoledo3's picture
Re: Plugin Installs

I'm going to guess (differently)... that you need to find the QC app in your developer folder do a get info (command I) on it, then switch it to open up on 32 bit mode.

Cybero may be right, but I think that, to my memory, PBMesh is likely compiled 32 bit only, b/c of the time that it came out (Leopard era), where QC was just 32 bit. Since it opens in 64 bit by default in SL, it probably wont register in the Patch Library unless QC is opened in 32 bit.

As far as running old versions of the app... you might run into problems, but patch loading would likely not be one. You probably wouldn't run into many/any problems with old versions of QC, bc not a lot of stuff referred to url's that changed, etc (I can't think of anything). Now, manually using old frameworks and stuff would be BAD.

Also, in my opinion, PBMesh has long been somewhat superseded by using the GL Quad structure. It's at least worth looking at.

cybero's picture
Re: Plugin Installs

Thinking this through further, it may be , larrylush , that you are running QC 3.1 because you are following the advice given on Paul Bourke's site that using the PBMesh plugin in QC 3.x works better with movie input than it does in the QC 4.0 application.

Funnily enough, I find that the stock Movie Importer works just fine with this patch on first time of asking in Lion, but, in only a slightly reliable way, consistent with the reportedly iMac build version related problems pertaining to the Movie Importer patch in Lion, suffice to say movie input is not reliable IMETD.

However, regarding static imagery, it works just fine. See attached picture for proof. In QC 4.5, 64 bit mode and PBMesh is loaded and is working. I'm actually none too sure that the GL Quad Structure can supersede the PBMesh patches functionality entirely, at least, not without appropriate scripting to produce a warpable or warping structure [either static warp or else via inputs say in Javascript kernel for the equivalent of the PBMesh's Delta u and Delta v and Theta].

PBMeshLion64bit.png1.05 MB